Skype for Business/Lync Master Replicator Agent would not start

One of my clients had a problem after Skype for Business Cumulative Update was installed. The Skype for Business Master Replication Agent would start and stay up for about a minute or so. After that, the service would stop with multiple errors in Application Log:

Event ID 1000: Application Errormra1

Event ID 1026: .NET Runtimemra2

At the same time, there is an error in the Lync Server log:

Event ID 2007: LS Master Replicator Agent Servicemra3

Replication stopped at the time when I stopped all Skype for Business services as required by the Cumulative Update installation.

mra4

It stays like this forever. No replication, time does not change.

I spent hours troubleshooting. I tried many different fixes, but nothing worked.

After a long struggle, I remembered that I had read somewhere that I can uninstall and reinstall each component separately, so I started thinking, why not… and I decided to give it a try.

In Microsoft Control Panel under Uninstall Program section, I uninstalled Skype for Business Server 2015, Core Management Server.mra5

After that, all I had to do is to run the Step 2 in the Skype for Business Deployment Wizard. When I started the Skype for Business Master Replication Agent, everything replicated and worked without any issues.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s